Update installed, but keeps restarting itself!

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Scott G Vaal

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Update installed, but keeps restarting itself!

Postby Dolan Classen » Sat, Dec 05 2009, 12:03PM

I have successfully installed the latest update for ecabs 5.2 build 6, with no errors. Ecabs appears to be running fine after installation. However, at random times, the update installation tries to re-run itself. It gets to a certain point where it wants to find the "eCabinet Systems v5.2 Build 6.msi" file. This is not the file that downloaded from your website, that one was a self-executing extension (.exe). So, I don't have the file it wants.

It seems to happen mostly when I am accessing my internet browser (Firefox) or other internet-based applications. I just have to cancel the installation every time it happens. Sometimes it goes away nicely, and sometimes it gets in a loop where each time I cancel it restarts on its own. When I do get it to cancel, it gives "Error 1706. No valid source code could be found for product eCabinet Systems v5.2 Build 6. The Windows Installer cannot continue." Any ideas other than doing a complete uninstall and reinstall of eCabs?

Dell Inspiron 530/Intel Quad-Core Q6600/3GB Mem/Windows XP Pro

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Mon, Dec 14 2009, 11:42PM

OK NOW I NEED SOME SERIOUS HELP... THERMWOOD HELP - YOUR UPDATE CORRUPTED MY COMPUTER!

I got fed up with the installation restarting whenever it felt like it, so I UNINSTALLED ECABS COMPLETELY, and guess what... The same problem i described in the initial post, about the update installation restarting, is still happening!

HELP?!

Joe Dusel
eCabinets Beta Tester
Posts: 1117
Joined: Tue, May 17 2005, 9:40PM
Location: Vista, CA, U.S.A.
Contact:

Re: Update installed, but keeps restarting itself!

Postby Joe Dusel » Tue, Dec 15 2009, 12:54AM

You might want to just give Thermwood a call. I think you would get a faster response that way.

Joe
CFT411 http://www.cft411.com
Intel i7 920 @ 2.67GHz, 6 GB RAM, Windows 7 64 bit, NVIDIA Geforce GT220 (1GB)

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Tue, Jan 12 2010, 2:52PM

Was hoping that v6 would fix this... but alas... I uninstalled v5 completely, even did registry search to remove all traces of eCabs. Then did a clean install of v6 and guess what? It keeps doing the same thing, occasionally having to do some kind of reinstall. Am I the only one having this problem?

Joe Dusel
eCabinets Beta Tester
Posts: 1117
Joined: Tue, May 17 2005, 9:40PM
Location: Vista, CA, U.S.A.
Contact:

Re: Update installed, but keeps restarting itself!

Postby Joe Dusel » Tue, Jan 12 2010, 3:03PM

What did the folks at Thermwood say when you called them?

Joe
CFT411 http://www.cft411.com
Intel i7 920 @ 2.67GHz, 6 GB RAM, Windows 7 64 bit, NVIDIA Geforce GT220 (1GB)

User avatar
Larry Epplin
Thermwood Team
Posts: 645
Joined: Tue, May 17 2005, 12:44PM
Location: Thermwood

Re: Update installed, but keeps restarting itself!

Postby Larry Epplin » Tue, Jan 12 2010, 3:37PM

If the message is looking for the 5.2 Build 6 msi, you should re-run this update and select the Remove option. Hopefully that will remove it. When an installer is popping up trying to install it is normally due to a file that came with the installation being altered or removed. Here is a link to the 5.2 Build 6 update.

http://order.ecabinetsystems.com/update ... Build5.asp

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Thu, Jan 14 2010, 1:11PM

Larry, I have attached a snapshot of what it looks like when it happens. It has been random at times, but lately I have noticed that it is happening everytime I open an internet browser. Firefox or IE, doesn't matter. When the browser is not running at all, and I just go click on the icon to run the application, immediately after the browser comes up, the Ecabs reloading message appears.
Attachments
Clip1.jpg
Clip1.jpg (38.51 KiB) Viewed 1909 times

User avatar
Larry Epplin
Thermwood Team
Posts: 645
Joined: Tue, May 17 2005, 12:44PM
Location: Thermwood

Re: Update installed, but keeps restarting itself!

Postby Larry Epplin » Thu, Jan 14 2010, 1:47PM

According to what you are saying, maybe the browser application is affecting a file for the eCabinet installer. Hopefully by looking in the Event Viewer we can find the problem. To get to the Event Viewer go to Control Panel -> Administrative Tools -> Event Viewer. Click on Applications and open the events that occurred when the installer popped up. Then post what you find for each event.

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Thu, Jan 14 2010, 1:50PM

I have also taken a couple snapshots of my add/remove programs window, and it's problems. I have v5.2 still listed, even though I have uninstalled it. If I try to uninstall, it comes up with the error shown in Clip2.jpg. I also had previously installed ESL6872-2 Base Cabinets add-on (under v5.2), and uninstalled it. It also still shows up in add/remove programs, and gives the error shown in Clip3.jpg when I try to uninstall again. I also use a computer maintenance product called Ccleaner... it can uninstall programs also, and remove their entries in the program list. When I click on "Delete Entry", it says "Cannot delete MSI Installer".

There is definitely something going on with the installers of these programs. What I would really like to do is have some way of wiping any record of Thermwood products from my machine, and starting over with a fresh clean install of v6. Short of reloading Windows and all other applications, I don't know what else to try.
Attachments
Clip3.jpg
Clip3.jpg (74.78 KiB) Viewed 1897 times
Clip2.jpg
Clip2.jpg (74.89 KiB) Viewed 1897 times

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Thu, Jan 14 2010, 2:04PM

OK I did check Event Viewer. There are three events that happened upon opening the internet browser, two are of type "Warning", and one is "Information". They are posted below, in order.


Event Type: Warning
Event Source: MsiInstaller
Event Category: None
Event ID: 1004
Date: 1/14/2010
Time: 10:57:53 AM
User: DCMAIN\dc
Computer: DCMAIN
Description:
Detection of product '{03F80425-1507-4A73-91F9-B2C2DA0CCFF7}', feature 'eCabinet_Systems_Files', component '{BADC3155-2F66-4143-B2FA-D8E18C6AF7C7}' failed. The resource 'C:\Documents and Settings\All Users\Application Data\Thermwood\eCabinet Systems\' does not exist.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type: Warning
Event Source: MsiInstaller
Event Category: None
Event ID: 1001
Date: 1/14/2010
Time: 10:57:53 AM
User: DCMAIN\dc
Computer: DCMAIN
Description:
Detection of product '{03F80425-1507-4A73-91F9-B2C2DA0CCFF7}', feature 'eCabinet_Systems_Files' failed during request for component '{3207D1B1-80E5-11D2-B95D-006097C4DE24}'

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type: Information
Event Source: MsiInstaller
Event Category: None
Event ID: 11728
Date: 1/14/2010
Time: 10:58:55 AM
User: DCMAIN\dc
Computer: DCMAIN
Description:
Product: eCabinet Systems 6.0 Build 1 -- Configuration completed successfully.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7b 30 33 46 38 30 34 32 {03F8042
0008: 35 2d 31 35 30 37 2d 34 5-1507-4
0010: 41 37 33 2d 39 31 46 39 A73-91F9
0018: 2d 42 32 43 32 44 41 30 -B2C2DA0
0020: 43 43 46 46 37 7d CCFF7}

User avatar
Larry Epplin
Thermwood Team
Posts: 645
Joined: Tue, May 17 2005, 12:44PM
Location: Thermwood

Re: Update installed, but keeps restarting itself!

Postby Larry Epplin » Thu, Jan 14 2010, 2:06PM

The way to remove these particular installs is to run the install again and select the Remove option. If you no longer have the exe for these you can download them from the following locations.

For the library installs:

http://www.ecabinetsystems.com/ecabinet ... raries.htm

For the 5.2 Build 5 install

http://order.ecabinetsystems.com/update ... Build5.asp


NOTE: I just noticed your Event Viewer post. I'll get back to you on this...

User avatar
Larry Epplin
Thermwood Team
Posts: 645
Joined: Tue, May 17 2005, 12:44PM
Location: Thermwood

Re: Update installed, but keeps restarting itself!

Postby Larry Epplin » Fri, Jan 15 2010, 10:11AM

From the information you have posted it appears that there is an add-on in your browser(s) that is conflicting with a module that is used by eCabinets Systems. If you don't mind we would greatly appreciated if you tried removing add-ons in your browser(s) until the problem does not occur any longer. Then let us know which one was the culprit so that we may reproduce the problem here and find a resolution with our installer.

Dolan Classen
New Member
Posts: 13
Joined: Fri, Oct 16 2009, 12:16PM
Company Name: Douglas County Cabinet Service

Re: Update installed, but keeps restarting itself!

Postby Dolan Classen » Mon, Jan 18 2010, 4:55PM

OK I have gone through all the add-ons in Firefox, to no avail. I removed about 5 add-ons, one at a time, restarting Firefox each time. Each time I restarted Firefox, within about 5-10 seconds after Firefox finished loading, the eCab reloading thing occured again, each time.

User avatar
Larry Epplin
Thermwood Team
Posts: 645
Joined: Tue, May 17 2005, 12:44PM
Location: Thermwood

Re: Update installed, but keeps restarting itself!

Postby Larry Epplin » Tue, Jan 19 2010, 8:29AM

I'm not really sure what to do next here. According to the Event Viewer information there is definitely something inferring with a component that eCabinet Systems uses. Maybe an uninstall then reinstall of FireFox?

Does anyone else on the forum have this conflict?

Dennis G. Blackburn

Re: Update installed, but keeps restarting itself!

Postby Dennis G. Blackburn » Tue, Jan 19 2010, 8:45AM

I'm havingthe same problem everytime I try to open NIKON VIEW to see my photo library.


Return to “eCabinet Systems Software”

Who is online

Users browsing this forum: Google [Bot] and 9 guests