PTrouble with stretcher in part editor.

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Scott G Vaal

Tim Massa
Senior Member
Posts: 190
Joined: Tue, Sep 19 2006, 7:30PM

PTrouble with stretcher in part editor.

Postby Tim Massa » Thu, Jan 23 2014, 9:31AM

Display panels too!
I've been trying to put some 5mm holes in an up/dpwn oriented stretcher that was created for a blind corner cabinet. The stretcher is serving as a "4th" side that have an adjacent base cabinet butting into it from the adjacent perpendicular wall.
The Stretcher will be getting the mounting plates on the pack side of it for some Blum hinges. The holes were drawn up in Turbocad and saved off as a dxf then imported into part editor. Using the 'create pocket' and selecting the holes I set the depth to .625".
The option to "remove geometry" display panel after the operation comes up next. Select yes. Vector hole disappears but no outline of a pocket hole remains. Go to main cab editor and the stretchers thickness has been reduced by .625". For some reason it will not apply the pocket operation of the 5mm holes correctly. Does the same thing in to a display panel.
Odd as I have been putting shelf pin holes and hinge mount holes in cabinets, where the software is not able, for some time using this method. Has been performing pocket cuts really well for other pocket cut operations in this job. Just hit this problem recently.
As an aside, I've noticed that 'creating apart using closed contour will rarely work with any radius in the shape if imported as a DXF. Using the negative space around the sought after shape as a cookie cutter for pocket cutting has been the work around and has worked fine using the same radius line work. Any one else seeing this in part editor and have they found a solution for it?

User avatar
Scott G Vaal
Thermwood Team
Posts: 1741
Joined: Tue, May 17 2005, 12:44PM
Company Name: Thermwood Corporation
Location: Thermwood Corp: Dale, Indiana
Contact:

Re: PTrouble with stretcher in part editor.

Postby Scott G Vaal » Thu, Jan 23 2014, 11:07AM

Tim,

Could you please attach the cabinet(s) that you are having this issue with? Please provide the geometry (DXF file(s)) and the steps you are taking. Please provide the cab and steps for both issues you mention in this post and we will take a look at it. Thanks in advance.
Regards,

Scott Vaal
-Thermwood/eCabinet Systems-
Dell Precision / Xeon E3-1240 / 8GB RAM /NVIDIA Quadro K2000

Tim Massa
Senior Member
Posts: 190
Joined: Tue, Sep 19 2006, 7:30PM

Re: PTrouble with stretcher in part editor.

Postby Tim Massa » Thu, Jan 23 2014, 12:27PM

Cabinet
Attachments
B-2.hsf
(404.02 KiB) Downloaded 48 times

Tim Massa
Senior Member
Posts: 190
Joined: Tue, Sep 19 2006, 7:30PM

Re: PTrouble with stretcher in part editor.

Postby Tim Massa » Thu, Jan 23 2014, 12:30PM

Scott,

I'll have to e-mail you the DXF as the web site doesn't seem to be uploading the file.

Tim Massa
Senior Member
Posts: 190
Joined: Tue, Sep 19 2006, 7:30PM

Re: PTrouble with stretcher in part editor.

Postby Tim Massa » Thu, Jan 23 2014, 1:16PM

Whoops! I remembered to remember that we have to zip files on forum unlike the HSF's.

Ok. All I did was drag the up down stretcher into the part editor and then the next whachamacallit editor where you can load a DXF file from.

Return to part editor. Right click and select 'create pocket using closed contour'.

Select any of the 5mm holes.

Mouse down to the 'Next' button to bring up the depth of cut panel. I plugged in .625" for depth of pocket. also tried .25".

Remove geometry after operation or don't remove the geometry. it didn't matter.

Then mouse up to hit main editor button. Tell it Yaaas i want my changes.

Go to main cab editor and note the changes to the thickness of stretcher panel. Mine kept reducing the panel thickness to the amount specified for depth of pocket in the part editor.


I also tried loading a display panel of same size, though you have to remember to remember the length and widths are reversed when loading a display panel from what the pop up information panel for the stretcher displays when you hover over it. If you do it that way the display panel is 90 degrees out and won't work with the DXF that you drew. Same results as the stretcher. Reduced panel thickness by amount specified in pocket operation.

Hope this helps,

Tim
Attachments
Blind corner mnt plate holes.zip
(1.49 MiB) Downloaded 48 times

User avatar
Scott G Vaal
Thermwood Team
Posts: 1741
Joined: Tue, May 17 2005, 12:44PM
Company Name: Thermwood Corporation
Location: Thermwood Corp: Dale, Indiana
Contact:

Re: PTrouble with stretcher in part editor.

Postby Scott G Vaal » Thu, Jan 23 2014, 2:45PM

Tim,

The issue is happening due to your dxf geometry's Z position. It is drawn at -16.7344 in the Z axis. Not sure why it is that way, but it is causing this issue. If you re-position the Z level of the geometry to zero and then re-dxf it, it will work fine. I will attach a version of the dxf with my modifications for you to use or review. We will investigate what we can do on our side to handle this situation in the future. For now, ensure it is at zero on Z. Try the "Creating a part with Closed Contour" issue you spoke of with the Z positions at zero and see if it resolves that as well. If not, please get me some files for that scenario. And thank you for getting the other files to us.
Attachments
BLIND CORNER MNT PLATE HOLES_SGV2.zip
(60.52 KiB) Downloaded 49 times
Regards,

Scott Vaal
-Thermwood/eCabinet Systems-
Dell Precision / Xeon E3-1240 / 8GB RAM /NVIDIA Quadro K2000

Tim Massa
Senior Member
Posts: 190
Joined: Tue, Sep 19 2006, 7:30PM

Re: PTrouble with stretcher in part editor.

Postby Tim Massa » Thu, Jan 23 2014, 5:15PM

Thanks Scott,

That's awesome! Glad it was the DXF not E-cabs. Odd. Don't know how that z value got where it did. It's only 2-d design. Leave it to me.
That's great. Ill post you a bob working 'create part using closed contour' DXF as soon as I generate another. Thanks again for the help. It's appreciated.

Tim

User avatar
Scott G Vaal
Thermwood Team
Posts: 1741
Joined: Tue, May 17 2005, 12:44PM
Company Name: Thermwood Corporation
Location: Thermwood Corp: Dale, Indiana
Contact:

Re: PTrouble with stretcher in part editor.

Postby Scott G Vaal » Thu, Jan 23 2014, 7:31PM

Tim Massa wrote:Thanks Scott,

That's awesome! Glad it was the DXF not E-cabs. Odd. Don't know how that z value got where it did. It's only 2-d design. Leave it to me.
That's great. Ill post you a bob working 'create part using closed contour' DXF as soon as I generate another. Thanks again for the help. It's appreciated.

Tim


No problem. In the next version, it looks like we will be able to have eCabSys automatically correct any of this type of Z difference when a DXF or X_T is loaded.
Regards,

Scott Vaal
-Thermwood/eCabinet Systems-
Dell Precision / Xeon E3-1240 / 8GB RAM /NVIDIA Quadro K2000


Return to “eCabinet Systems Software”

Who is online

Users browsing this forum: Exabot [Bot] and 9 guests