Problems with eCabinets running Parallels 11 on Mac

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Scott G Vaal

Bill Ward
New Member
Posts: 13
Joined: Sat, Oct 01 2005, 9:19PM
Location: Huxley, IA

Problems with eCabinets running Parallels 11 on Mac

Postby Bill Ward » Fri, Oct 30 2015, 9:18AM

I have been running eCabinets on a MacBook Pro for several years w/o problems. I have used Parallels versions up through 10 w/o problems. When Mac released the operating system upgrade to El Capitan, I upgraded to Parallels 11 as Parallels said that was designed to work with the new operating system.

Once I upgraded to Parallels 11, all images stopped working in eCabinets.

In Parallels 11, I have the following 3D Acceleration options: Disabled, DirectX9, or DirectX10.
- If I select Disabled, eCabinets will display the images when drawing a room but it render very slowly and is unusable.
- If I select either of the DirectX options, the design area in eCabinets will be white and not show any cabinets.

I understand that eCabinets uses OpenGL but there is not an option for to use that for 3D Acceleration in Parallels 11.

Has anyone else seen this problem or have suggestions/solutions? I have contacted Parallels technical support about whether they support OpenGL in version 11 and can't get a straight answer.

This is really holding me up. Any help would be appreciated.
Bill

Rick Deskins
Thermwood Team
Posts: 828
Joined: Tue, May 17 2005, 12:47PM
Company Name: Thermwood
Country: UNITED STATES
Location: Thermwood

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Rick Deskins » Fri, Oct 30 2015, 10:26AM

Have you uninstalled the old parallels tools and installed the newer version of parallels tools?
Did you make sure to set the power option to better proformance?

http://kb.parallels.com/en/112476
Rick Deskins
eCabinet Systems Programmer
Dell Precision / Xeon E3-1240 / 8GB RAM/ AMD FirePro V4900

Bill Ward
New Member
Posts: 13
Joined: Sat, Oct 01 2005, 9:19PM
Location: Huxley, IA

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Bill Ward » Fri, Oct 30 2015, 10:51AM

Thanks for the reply.

I have not tried uninstalling and re-installing Parallels Tools. I will try that later this afternoon after I am done with client meetings and see if that helps.

I mostly have it set to better performance as shown in the link. But as far as enabling the 3D Acceleration in the link you sent, there is no longer just a check box to enable 3D Acceleration. There is a drop-down box with the options Disable, DirectX9, or DirectX10. That is what has got me confused. Do you know what option I should be selecting there?

Thanks!

Bill Ward
New Member
Posts: 13
Joined: Sat, Oct 01 2005, 9:19PM
Location: Huxley, IA

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Bill Ward » Fri, Oct 30 2015, 12:53PM

I tried un installing and re-installing Parallels Tools and there was no change. I added a screenshot of my available selections for 3D Acceleration. Do you have any ideas?

Thanks again for your help.
Bill
Attachments
Screen Shot 2015-10-30 at 12.51.20 PM.png

Rick Deskins
Thermwood Team
Posts: 828
Joined: Tue, May 17 2005, 12:47PM
Company Name: Thermwood
Country: UNITED STATES
Location: Thermwood

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Rick Deskins » Fri, Oct 30 2015, 1:47PM

I think it should be directx 10 since it is windows 10. Can you make sure that parallels is using the discrete video card?

Switching Between Integrated and Discrete Video Adapter

Switching between integrated and discrete video cards is pretty simple – the main thing is to send appropriate parameters when creating an OpenGL context (and react to switching events by recreating contexts), there is nothing else we do ‘manually’. Please note that this technology has no similarities with SLI/Crossfire whatsoever.

To switch between the adapters, go to virtual machine configuration window -> Options -> Optimization - Power
For integrated graphics (CPU) set 'Longer battery life'
For discrete video card set 'Better performance'


Another thing to try is swapping to Games Only or Design Profile.

http://kb.parallels.com/122658
Rick Deskins
eCabinet Systems Programmer
Dell Precision / Xeon E3-1240 / 8GB RAM/ AMD FirePro V4900

Bill Ward
New Member
Posts: 13
Joined: Sat, Oct 01 2005, 9:19PM
Location: Huxley, IA

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Bill Ward » Fri, Oct 30 2015, 3:26PM

Thanks for the ideas. Good to know about switching between the integrated and discrete video cards.

I did have it set to 'Better Performance' so it should be using the discrete. I get the exact same performance no matter if it is set to 'Longer Battery Life' of 'Better Performance'. That is, if 3D Acceleration is disabled, it will draw but extremely slow. With either DiscreteX enabled, it does not draw at all.

I also tried the gaming mode which didn't change the way eCabinets performs.

Interestingly, there no longer seems to be a 'Design' profile.

Any other ideas?
Attachments
Screen Shot 2015-10-30 at 3.21.42 PM.png
Screen Shot 2015-10-30 at 3.17.17 PM.png

Rick Deskins
Thermwood Team
Posts: 828
Joined: Tue, May 17 2005, 12:47PM
Company Name: Thermwood
Country: UNITED STATES
Location: Thermwood

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Rick Deskins » Fri, Oct 30 2015, 8:54PM

Looks like for version 11, design profile is only available for the pro edition. I know this is a pain to do, but could you downgrade to version 10 with the latest updates (it support windows 10). There may be an issue with version 11, your video card, opengl, and/or el captian.
Rick Deskins
eCabinet Systems Programmer
Dell Precision / Xeon E3-1240 / 8GB RAM/ AMD FirePro V4900

Bill Ward
New Member
Posts: 13
Joined: Sat, Oct 01 2005, 9:19PM
Location: Huxley, IA

Re: Problems with eCabinets running Parallels 11 on Mac

Postby Bill Ward » Sat, Oct 31 2015, 9:50AM

YES! That did it. I downgraded Parallels back to version 10 and it works. So it does appear to be a problem with Parallels 11.

It will be interesting to see if others have the same problem with Parallels 11 or if it was just me for some reason.

Thanks for your help! Now just need to catch up with some designs. :)

-------------------
In case there are others experiencing the same issue, here are the steps I took to revert back to Parallels 11.

Follow http://kb.parallels.com/en/123349 procedure to send it to the trash and emptied trash.

Rebooted mac.

Ran http://kb.parallels.com/Attachments/kcs ... remove.zip as noted in the parallels kb article above.

Rebooted mac.

Installed Parallels 10 from http://www.parallels.com/directdownload/pd10

Followed the install process. First time it opened Windows, it installed Parallels tools. I rebooted the Windows as it requested and also rebooted the Mac.

Probably didn't need to reboot the Mac so many times but was just being cautious to make sure it cleaned everything up.


Return to “eCabinet Systems Software”

Who is online

Users browsing this forum: No registered users and 14 guests