Tool Measuring Problem

Discuss Thermwood 3-axis Machinery, Controller, and Software.

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Rich Kasten

Andrew Moura
New Member
Posts: 8
Joined: Mon, Mar 02 2009, 12:41PM
Company Name: Andex

Tool Measuring Problem

Postby Andrew Moura » Mon, Mar 02 2009, 1:40PM

Hello everyone,

I am having a problem measuring a tool.

After I select the tools I want to measure, and the tool is brought above the sensor, instead of the tool being lowered slowly, the tool is raised slowly until it cannot go any higher in which case I get an error 3052 Z axis is out of bounds.

I tried re-measuring a tool that had worked before this happened and it is also doing the same thing now.

Is there a way to fix this?

Thank You,

Nemanja Vujkovic
Senior Member
Posts: 222
Joined: Wed, Feb 21 2007, 1:29PM
Location: STL, MO

Re: Tool Measuring Problem

Postby Nemanja Vujkovic » Mon, Mar 02 2009, 1:52PM

the sensor is probably jamed with dirt. Remove the sponge thats around it, spray some WD-40 in there and press it with your hand couple times to see hove easy it slides up and down. If you feel some restriction, you might have to remove the top of the sensor and cleen the inside with aceton and than spray some lubrican in there. Check on the bottom side if there is a biger chunck of debris rstuck in there.


Gary Urlacher
Junior Member
Posts: 76
Joined: Mon, Jun 02 2008, 11:39AM

Re: Tool Measuring Problem

Postby Gary Urlacher » Mon, Mar 02 2009, 6:26PM

I have to agree, I had the same problem. It is always a sticky tool measuring switch.

Michael Kowalczyk
eCabinets Beta Tester
Posts: 284
Joined: Tue, May 10 2005, 11:35AM
Location: Houston, Texas

Re: Tool Measuring Problem

Postby Michael Kowalczyk » Wed, Mar 04 2009, 6:18PM

Hey Andrew,
I have the exact problem once in a while. My CNC's are both made in 2002 and one is a C40 and the other is a C42. Both have the same tool length measure device. A milky plastic 2"+- disc on top with 3 small Allen screws. once you remove them there is a spring under it and a plastic sleeve. blow some clean dry air on the metal post and be sure not to loose the tiny screws. Tap it up and down a few times and then reassemble. It works every time for me. I do not use any liquid on it at all. I would ask a Thermwood service tech 1st. If any thing maybe an LPS contact cleaner or similar. Funny thing is that the C40 does it sporadically but the C42 I don't think it has ever done it. I have asked about replacing it with a proximity sensor but they say "been there done that" without good results. So this is a temp fix and maybe 10 minutes of time but it's FREE.
Michael Kowalczyk, GM

HP-Elite Quad Core Q6700-4 MB ram, Nvidia GeForce 512 MB Dual HP 22" flat panels, Windows 7 ultimate 64bit SP1

Return to “Thermwood 3-Axis Machinery”

Who is online

Users browsing this forum: No registered users and 5 guests