Tool change problems

Discuss Thermwood 3-axis Machinery, Controller, and Software.

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Rich Kasten

User avatar
Saul Sawyer
Junior Member
Posts: 50
Joined: Fri, Jul 22 2005, 11:16AM
Location: Ft. Worth, TX

Tool change problems

Postby Saul Sawyer » Thu, Sep 29 2005, 11:11AM

Hi, My machine is being grumpy this morning and I was wondering if anyone on here has ever had a similar problem.

If, for example, you call for tool #3 and THAT TOOL IS ALREADY IN THE ROUTER HEAD when you push start, the motor will start up and immediately put itself into e-stop. If there is a DIFFERENT TOOL IN THE HEAD, it will drop that one off, pick up the one you call for, the motor will start and it will run fine. So, I can still run parts, but I have to make sure I've got a different tool than what I am using in there or I get the error. I've tried with all the different tools and tool holders, but that doesn't seem to be the problem.

The error I get when this occurs is:

Z Draw bar not up while spindle is moving (Input 2 open or 1 closed) & (15 open or 11 closed)

When I watch the input or output screens during a tool change, everything looks like it is functioning properly.

I'm still trying to work this out with tech service but wanted to post on here to see if anyone else has a fix.

Thanks in advance for any help :wink:

Saul Sawyer
Lauritzen & Makin Inc.

David Hall
eCabinets Beta Tester
Posts: 588
Joined: Tue, May 17 2005, 12:41PM
Location: Stamford, CT USA

Postby David Hall » Thu, Sep 29 2005, 6:13PM

The only time I ran into something like this, it turned out to be a problem in the g-code. Somehow part of a tool change macro call made it's way into my code.

Try running another file or check the file you're running closely for an M?? that doesn't look like it belongs.

David Hall
Hall's Edge Inc.
eCabinets Machining Services

Return to “Thermwood 3-Axis Machinery”

Who is online

Users browsing this forum: Google [Bot] and 6 guests