Dxf Files

Discuss Thermwood 3-axis Machinery, Controller, and Software.

Moderators: Jason Susnjara, Larry Epplin, Clint Buechlein, Rich Kasten

Bill OConnell
Senior Member
Posts: 121
Joined: Mon, Jun 13 2005, 12:26PM
Location: Calverton, New York
Contact:

Dxf Files

Postby Bill OConnell » Thu, Jun 30 2005, 7:40PM

I have used DXF files to cut individual parts, but my experience has been hit or miss. I use TurboCAD version 10.2. The problems seem worse when I try to combine types of lines. What I am currently trying to do is cut some arches. I've done this before without a hitch but now I am getting the following error:

\"A common close point was not found for an outline operation, file xxx will not be included in the nest.\"

I verified the lines were on the right layer \"Outlinez0p75\". I also verified that the vertices of each line were touching, I even used the Modify Line to extend the lines to make sure the program made them touch, rather than my eye. I also re-drew them with exact measurements.

Does anyone have any clues as to what I am missing?
Woodworking the Way You Want It

Nick M Singer
Guru Member
Posts: 828
Joined: Fri, Jun 17 2005, 12:23AM
Location: South Africa

Postby Nick M Singer » Fri, Jul 01 2005, 12:02AM

Hi Bill
Yes it is a pain!! I use Tcad V10 as well and have experienced similar problems. There are essentially two issues; one relates of course to the eternal American Imperial / Metric conflict and the other to the closed point problem you have described. You must make sure that you draw each primitive springing from a vertex snap point thereby ensuring each outline you are drawing is completely bounded. I have found that using a fillet with a 0 setting or some such trick does not work. you must use snap to vertex. Oh yes! also make sure everything in the chain is on the same layer. Hope this has been useful.
Nick

Nick M Singer
Guru Member
Posts: 828
Joined: Fri, Jun 17 2005, 12:23AM
Location: South Africa

Postby Nick M Singer » Fri, Jul 01 2005, 12:03AM

Hi Bill
Yes it is a pain!! I use Tcad V10 as well and have experienced similar problems. There are essentially two issues; one relates of course to the eternal American Imperial / Metric conflict and the other to the closed point problem you have described. You must make sure that you draw each primitive springing from a vertex snap point thereby ensuring each outline you are drawing is completely bounded. I have found that using a fillet with a 0 setting or some such trick does not work. you must use snap to vertex. Oh yes! also make sure everything in the chain is on the same layer. Hope this has been useful.
Nick

User avatar
Bill Rutherford
eCabinets Beta Tester
Posts: 386
Joined: Tue, May 10 2005, 5:23AM
Location: Lancaster, NH
Contact:

Postby Bill Rutherford » Fri, Jul 01 2005, 5:28AM

I use DXF files all the time. The biggest thing is to make SURE you drawing is closed. As Nick suggested use snap to Vertex. If your drawing is not closed, or if there is a tail on one of your lines then the machine is not sure what you are asking for. Care when drawing the parts is the easiest way around this. I would recommend taking the drawing that is causing you problems and zooming in very tight on all of the intersections between lines. Look for any gap or overhang .001 is enough to cause a problem. If there is any gap or overhang use Tcad's trim function. If you would like to post your file (as a DXF) I will be happy to take a look. Aside from some parts we cut in MasterCam virtually all of the rest of our parts are designed as DXF files, and I do often have a problem these days. I design and cut in Imperial units so I can not comment on the conversion problem.

Edit: Another thing I forgot to mention earlier that can cause MAJOR problems with DXF conversions is overlapping geometry. Check your drawing to make sure you have not drawn one line twice (one over top of the other)


Return to “Thermwood 3-Axis Machinery”

Who is online

Users browsing this forum: Bing [Bot] and 8 guests